Service Degradation
Resolved
Apr 23, 2026 at 7:00pm UTC
A downstream resource used by Kalepa's platform had performance issues which in turn degraded latency and performance of several dependent services. Once alternate capacity was provided for the degraded resource, caches had to be re-populated which led a to a delay in recovery. Resources are now over-provisioned for the compromised service and Kalepa is analyzing other dependencies and adding further instrumentation and resiliency around the resource.
Affected services
Created
Apr 23, 2026 at 5:28pm UTC
We are seeing elevated error rates and increased latency across Kalepa platform. We are investigating the root cause.
Affected services