Back to overview
Downtime
Global AWS DNS issue
Oct 20, 2025 at 7:08am UTC
Affected services
Kalepa Web App
Kalepa API
Resolved
Oct 20, 2025 at 9:29am UTC
A third-party AWS regional service disruption (underlying network layer) impacted components supporting Kalepa’s production stack, leading to downtime of dependent services.
No US customers were affected.
Affected services
Created
Oct 20, 2025 at 7:08am UTC
AWS DNS services are currently experiencing an outage, resulting in DynamoDB and RDS unavailability and making Copilot inaccessible.
Affected services